أستغفر الله العظيم ,, اللهم لك الحمد



العودة   منتديات داماس > برامج الكمبيوتر والانترنت > سيرفرات المايكروتك, صفحات هوت سبوت


مواضيع مميزة  


آخر عشرة مواضيع المواضيع النشطة


19-02-2015, 02:06 PM
thecoder غير متصل
عضو جديد
رقم العضوية: 550729
تاريخ التسجيل: Jan 2015
المشاركات: 22
إعجاب: 0
تلقى 0 إعجاب على 0 مشاركة
تلقى دعوات الى: 1 موضوع
مواضيع لم تعجبه: 0
تلقى 0 عدم اعجاب على 0 مشاركة
    #1  

طلب لتعديل كود ارسال نسخة من الباك اب الى الايميل


الأخوة الأعضاء

كان عندي الاسكربت هذا لكي يرسل لي نسخة باك اب على الايميل ، النسخة كانت 5.20
الان عندي نسخة 6.26
مارضي يشتغل معي
أرجو مساعدتي لتعديل الكود

وهذا هو الكود السابق

:log info "backup beginning now"
:local backupfile ([/system identity get name] . "-" . [/system clock get time])
/system backup save name=$backupfile
:log info "backup pausing for 10s"
:delay 10s
:log info "backup being emailed"
/tool e-mail send to="fares022@gmail.com" tls=yes subject=([/system identity get name] . \
" System Backup") file=$backupfile
:log info "backup finished"
:delay 10s;
/file remove $backupfile;
:log info message=fileremoved





المواضيع المشابهه
الموضوع كاتب الموضوع المنتدى مشاركات آخر مشاركة
استديو كامل لتعديل واضافة مؤثرات على الملفات الصوت للاندرويد Voice PRO v3.3.11 نسخة مدفوعة ABU.AMR تطبيقات برامج والعاب وثيمات الاندرويد Android 8 18-11-2016 07:55 PM
Resource Tuner 2.01 لتعديل وتخصيص وتعريب البرامج (نسخة محمولة) ربيع برامج 17 09-02-2015 04:36 PM
مطلوب نسخة ويندز اكس بي خام لتعديل لو سمحتم عندليب البريجات المنتدى العام لتصميم الأسطوانة 2 10-03-2014 07:11 PM
برنامج استعادة الايميل المسروق برامج اختراق الايميل شغال 100% مضمون aoneman أرشيف المواضيع المخالفة والمحذوفات 1 26-09-2011 12:18 PM
نسيت باسورد الايميل saber b3a7 صيانة الكمبيوتر وحلول الحاسب الألي - هاردوير 2 23-01-2011 04:39 AM

19-02-2015, 05:25 PM
mmhs_m غير متصل
مشرف سيرفرات المايكروتك
رقم العضوية: 436486
تاريخ التسجيل: Nov 2013
المشاركات: 3,000
إعجاب: 706
تلقى 1,434 إعجاب على 453 مشاركة
تلقى دعوات الى: 2531 موضوع
مواضيع لم تعجبه: 3
تلقى 0 عدم اعجاب على 0 مشاركة
    #2  
تفضل وننتظر الرد لابد يكون عندك حساب على gmail

/export file=export;:delay 40s
/tool e-mail send file=export.rsc to=******@gmail.com user=***** password=*****tls=yes server=74.125.45.109:25 subject=exportfile from=10;
:log info message=backupfinished;



19-02-2015, 07:39 PM
thecoder غير متصل
عضو جديد
رقم العضوية: 550729
تاريخ التسجيل: Jan 2015
المشاركات: 22
إعجاب: 0
تلقى 0 إعجاب على 0 مشاركة
تلقى دعوات الى: 1 موضوع
مواضيع لم تعجبه: 0
تلقى 0 عدم اعجاب على 0 مشاركة
    #3  
شكرا لك أخي على الرد

ولكن قمت بتتبع الكود ووجدت أن المشكلة في كلمة واحدة في الكود

الكود بعد التعديل

:log info "backup beginning now"
:local backupfile ([/system identity get name] . "-" . [/system clock get time])
/system backup save name=$backupfile
:log info "backup pausing for 10s"
:delay 10s
:log info "backup being emailed"
/tool e-mail send to="fares022@gmail.com" start=yes subject=([/system identity get name] . \
" System Backup") file=$backupfile
:log info "backup finished"
:delay 10s;
/file remove $backupfile;
:log info message=fileremoved
التعديل تم في كلمة tlr تم استبدالها بكلمة start

20-02-2015, 09:27 AM
mmhs_m غير متصل
مشرف سيرفرات المايكروتك
رقم العضوية: 436486
تاريخ التسجيل: Nov 2013
المشاركات: 3,000
إعجاب: 706
تلقى 1,434 إعجاب على 453 مشاركة
تلقى دعوات الى: 2531 موضوع
مواضيع لم تعجبه: 3
تلقى 0 عدم اعجاب على 0 مشاركة
    #4  
تحياتى لك اخى الكريم


/export file=export;:delay 40s
/tool e-mail send file=export.rsc  to=******@gmail.com user=*****  password=*****tls=yes server=74.125.45.109:25 subject=exportfile  from=10;
:
log info message=backupfinished

20-02-2015, 05:49 PM
thecoder غير متصل
عضو جديد
رقم العضوية: 550729
تاريخ التسجيل: Jan 2015
المشاركات: 22
إعجاب: 0
تلقى 0 إعجاب على 0 مشاركة
تلقى دعوات الى: 1 موضوع
مواضيع لم تعجبه: 0
تلقى 0 عدم اعجاب على 0 مشاركة
    #5  
لكن لازال عندي مشكلة

الا وهي أن عندي سكربتين :
الأول : يعمل باك اب لنظام المايكروتك وهو الذي سبق ذكره في المشاركة السابقة ، وهذا لا اشكال الان فيه .

الثاني : يعمل باك اب لليوزر منجر ، وهذا هو الكود :

:log info "backup beginning now"
:local backupfile ([/system identity get name] . "-" . [/system clock get time])
/tool user-manager database save name=$backupfile
:log info "backup pausing for 25s"
:delay 25s
:log info "backup being emailed"
/tool e-mail send to="fares022@gmail.com" start=yes subject=([/system identity get name] . \
" User-Manager  Backup") file=$backupfile
:log info "backup finished"
:delay 50s;
/file remove $backupfile;
:log info message=fileremoved
الثاني يعمل ولكن يظهر رسالة


الكود يعمل بشكل صحيح بدليل الرسائل التي تظهر في log
ولكن حين أن يصل لعمل ارفاق ملف الباك اب
file=$backupfile
تظهر رسالة الخطأ
كنت أظن أنه ربما من حجم الملف
ولكن حجم ملف الباك اب 880kb

فأين الخطأ يكمن ؟

شكرا

21-02-2015, 02:26 AM
bob libya15 غير متصل
عضو فعال
رقم العضوية: 548558
تاريخ التسجيل: Jan 2015
المشاركات: 117
إعجاب: 9
تلقى 17 إعجاب على 13 مشاركة
تلقى دعوات الى: 0 موضوع
مواضيع لم تعجبه: 0
تلقى 0 عدم اعجاب على 0 مشاركة
    #6  
ممكن الكود نبي نعمل نسخة على ايميل ممكن اخي النسخة كانت 5.26


21-02-2015, 04:48 PM
thecoder غير متصل
عضو جديد
رقم العضوية: 550729
تاريخ التسجيل: Jan 2015
المشاركات: 22
إعجاب: 0
تلقى 0 إعجاب على 0 مشاركة
تلقى دعوات الى: 1 موضوع
مواضيع لم تعجبه: 0
تلقى 0 عدم اعجاب على 0 مشاركة
    #7  
تفضل اخوي

هذا كان شرح كامل كنت سويته

نذهب أولا
Tools Email
ونضع الاعدادات التالية

Server 173.192.65.108 هذا اي بي سيرفر الجيميل ، أو على حسب اي بي البريد تبعك سواء هوتميل او ياهو

Port 587

From :

thecoder066@gmail.com هنا ايميلك

User :

thecoder066@gmail.com هنا ايميلك مرة اخرى

Password تضع باسوورد الايميل تبعك

----====
أولا : عمل نسخة احتياطية للسيستم نفسه

نذهب

System Script

وننشئ سكربت جديد
ونسميه system backup

ثم نلصق فيه هذا الاسكربت

:log info "backup beginning now"
:global backupfile ([/system identity get name] . "-" . [/system clock get time])
/system backup save name=$backupfile
:log info "backup pausing for 10s"
:delay 10s
:log info "backup being emailed"
/tool e-mail send to="thecoder066@gmail.com" tls=yes subject=([/system identity get name] . \
" System Backup") file=$backupfile
:log info "backup finished"
:delay 10s;
/file remove $backupfile;
:log info message=fileremoved
ثم موافق

ولكي نختبر السكربت نضعط
run script
ونروح
log
ونشوف ما الذي يظهر
وكذلك نفتح الايميل
سنلاحظ بعد قليل وصول ايميل بنسخة الباك اب

----==

ثانيا : عمل نسخة احتياطية لليوزر منجر

نذهب

System Script

وننشئ سكربت جديد
ونسميه UserManager BackUp

ثم نلصق فيه هذا الاسكربت

:log info "backup beginning now"
:global backupfile ([/system identity get name] . "-" . [/system clock get time])
/tool user-manager database save name=$backupfile
:log info "backup pausing for 25s"
:delay 25s
:log info "backup being emailed"
/tool e-mail send to="thecoder066@gmail.com" tls=yes subject=([/system identity get name] . \
" user-manager database Backup") file=$backupfile
:log info "backup finished"
:delay 25s;
/file remove $backupfile;
:log info message=fileremoved

ثم موافق

ولكي نختبر السكربت نضعط
run script
ونروح
log
ونشوف ما الذي يظهر
وكذلك نفتح الايميل
سنلاحظ بعد قليل وصول ايميل بنسخة الباك اب

----=

انتهينا من السكربت

الان نتجه الى

System Schedule

ونقوم بانشاء ملفين
بنفس اسماء السكربتات
الاول باسم
system backup
والثاني باسم
UserManager BackUp

ونضع في خانة
Start Time
الوقت الذي نريد مثلا نريد يعمل الساعة الخامسة فجرا فنكتب
05:00:00

ونضع في خانة
Interval
كل كم يشتغل هل كل ساعة مثلا أو كل ثلاث ساعات أو كل يوم ، فمثلا نجعله كل يوم يشتغل فنكتب
1d 00:00:00

فيصبح يعمل كل يوم الساعة الخامسة فجرا

ملاحظة مهمة : الاماكن اللي فيها الايميل

thecoder066@gmail.com تقوم بتغييرها بايميلك

وسلامتكم

21-02-2015, 10:37 PM
bob libya15 غير متصل
عضو فعال
رقم العضوية: 548558
تاريخ التسجيل: Jan 2015
المشاركات: 117
إعجاب: 9
تلقى 17 إعجاب على 13 مشاركة
تلقى دعوات الى: 0 موضوع
مواضيع لم تعجبه: 0
تلقى 0 عدم اعجاب على 0 مشاركة
    #8  
رووووووووووووووعة اخي بجد شرح مميز وسهل مشكوووووووووووووووور

 


طلب لتعديل كود ارسال نسخة من الباك اب الى الايميل


Powered by vBulletin® Version
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
The owner and operator of the site is not responsible for the availability of, or any content provided.
Topics that are written in the site reflect the opinion of the author.
جميع ما يُطرح من مواضيع ومشاركات تعبر عن رأي كاتبها ولا تعبر عن رأي مالك الموقع أو الإدارة بأي حال من الأحوال.