أستغفر الله العظيم ,, اللهم لك الحمد



العودة   منتديات داماس > برامج الكمبيوتر والانترنت > إدارة الشبكات و حلول ومشاكل الشبكات


مواضيع مميزة  


آخر عشرة مواضيع المواضيع النشطة


22-04-2013, 03:33 PM
شادى سوفت دمياط غير متصل
عضو جديد
رقم العضوية: 416648
تاريخ التسجيل: Apr 2013
المشاركات: 20
إعجاب: 0
تلقى 56 إعجاب على 11 مشاركة
تلقى دعوات الى: 3 موضوع
مواضيع لم تعجبه: 0
تلقى 0 عدم اعجاب على 0 مشاركة
    #1  

الموضوع الرسمى الخاص بسيرفرات الكاش وشروحاتها ..ِشادى سوفت




الموضوع الرسمى الخاص بسيرفرات

الموضوع الرسمى الخاص بسيرفرات
السادة الاعضاء
طول اليوم وانا بحاول اوصل لفكرة كويسة الا وهى:..
.
الموضوع الرسمى الخاص بسيرفرات
انا عامل هوتسبوت ودمج على بوردة 750 جى وشغالة تمام التمام مع 100 اون لاين يوميا وزى الفل
لازم اعمل حاجة تسرع التصفح مع الناس وفكرت فى ipcop
نجحت فى تسطيبه وبرمجته ..
حطيته بعدالسيرفر الميكروتيك بتاعى ولقيت الواجهة بتاعتى طلعت عملت يوزر 256 وفعلا قعدت شوية اتصفح واراقب السيرفر ولا حظت اللى هاتشوفوه فى الفيديو القادم ده
وتخيلوا 256 بحمل ب 12 ميجا للملفات التى تم تحميلها والانترنت داونلود مانجر 16 بورت كمان
هذه الصورة تم تصغيرها . إضغط على هذا الشريط لرؤية الصورة بحجمها الطبيعي . أبعاد الصورة الأصلية 600x50 .
الموضوع الرسمى الخاص بسيرفرات
اللى انا عاوزه عدة نقاط علشان ننزل شرح كامل ومحتاج مساعدة الناس اللى هنا او اللى سبق لهم التعامل مع السيرفر ده
(1) ازاى اربط ال ipcop قبل السيرفر يعنى لو عامل دمج لوحده هاحط الكاش بعده والميكروتيك عاوز اليوزر يعدى من التحديد اللى انا عامله علشان ياخد من الكاش..دى نقطة جوهرية؟؟؟
(2) انا جربت احط السيرفر الكاش بعد الدمج والهوتسبوت وظهرت الخلفية فعلا بس بالعقل كده هايبقى ايبى واحد بس اللى شغال عليه مثلا السيرفر بتاع التوزيع ادانى 10.1.1.70 يبقى الكل هايبقى بنفس الايبى ولا ايه الليلة؟..اعتقد هاتبقى فاشلة
(3) عاوز مشاركة جماعية علشان نستفاد
الموضوع الرسمى الخاص بسيرفرات

الموضوع الرسمى الخاص بسيرفرات

الموضوع الرسمى الخاص بسيرفرات

الموضوع الرسمى الخاص بسيرفرات

الموضوع الرسمى الخاص بسيرفرات


لينك تحميل 9 دقايق داخل السيرفر بيوزر 256 هل تتخيلون مايحدث؟


Download ipcop.rar for free on uploading.com


والشرح مرفوع يوتيوب

فى الرد القادم لى

الموضوع الرسمى الخاص بسيرفرات
طبعا الشرح كامل ينزل لما الموضوع يبقى معايا كامل لكن فى لينكات للناس علشان تجهز


http://garr.dl.sourceforge.net/proje...ll-cd.i386.iso



http://www.advproxy.net/download/ipc...y-3.0.6.tar.gz



http://update-accelerator.advproxy.n...r-2.1.3.tar.gz


وفيه شرح خالد جاد



ipcop by leroi.rar


منتظر الاجابات ليكتمل الموضوع واعدكم باذن الله تعالى لو نجح اللى فى دماغى هانزل بشروحات فيديو صوت وصورة باذن الله ونعمل ركن سيرفرات الكاش بمختلف انواعها نعلمها للناس والله المستعان
صورمن نظام السيرفر الكاش

الموضوع الرسمى الخاص بسيرفرات

الموضوع الرسمى الخاص بسيرفرات














الموضوع الرسمى الخاص بسيرفرات

الفيديو على يوتيوب

www.youtube.com/watch?v=lpXcErEfUrM&feature=player_embedded




وللعلم السيرفر دمج وهوتسبوت

الموضوع الرسمى الخاص بسيرفرات

محجوز لباقى الموضوعات





المواضيع المشابهه
الموضوع كاتب الموضوع المنتدى مشاركات آخر مشاركة
الموضوع الرسمي لمتابعه نسخة xp8 واعطاء اراءكم واقترحاتكم rinoum123456 المنتدى العام لتصميم الأسطوانة 15 22-04-2016 05:25 AM
فصل الالعاب الاونلاين والشات وفتح سرعتهم للمشتركين..ِشادى سوفت شادى سوفت دمياط إدارة الشبكات و حلول ومشاكل الشبكات 4 27-04-2013 03:47 PM
الموضوع الرسمي لدعوات لموقع demonoid مجانية ( تجديد 1 ) swenk دعوات لمواقع التورنت 143 10-06-2012 01:45 PM
الموضوع الرسمي لـــ مجلة عرب هارد وير morn in sky كتب تعليم البرامج والتقنية 7 19-09-2011 08:39 PM
الموضوع الرسمى لطلبات الدعوات لتراكر [ نادى التورنت ] hatem623 دعوات لمواقع التورنت 27 28-11-2010 02:37 AM

22-04-2013, 03:40 PM
شادى سوفت دمياط غير متصل
عضو جديد
رقم العضوية: 416648
تاريخ التسجيل: Apr 2013
المشاركات: 20
إعجاب: 0
تلقى 56 إعجاب على 11 مشاركة
تلقى دعوات الى: 3 موضوع
مواضيع لم تعجبه: 0
تلقى 0 عدم اعجاب على 0 مشاركة
    #2  
نبدا الجزء الاول باذن الله

اليوم سوف نعرف ما هو الكاش وانواعة والانظمة الداعمة لة وكيفية الاستفادة منة

وطرق ربط الانظمة المتاحة بالنظام الاكثر استخداما الا وهو المايكروتك

وخروج الكاش منة بسرعة الان.

طبعا الان بعض انواع سيرفرات الكاش الغير مجانية لمن يحب الشراء

والمواقع الرسمية لهم ودول مش محتاجين شرح لان الدعم الفنى بتاعهم ها يقوم معاك بكل شىء.

Html Agility Pack

AgilityCache



Html Agility Pack - Home


----

NimocPower



https://under-linux.org/forumdisplay.php?f=322


---

CacheMARA



CacheMARA -- The leading caching solution for ISPs on the market


--

ThunderCache



In


---

hyper cache taghos



HYPER -- Taghos


--------

Speedr



Speedr - BrByte


نجى بقى لاحلى حاجة احنا عوزنها طبعا المجانى

افضل سيرفرات كاش مجانية

والى ها اشرح عليهم Web Caches

--===

nginx



nginx news


----

Varnish- Cache



https://www.varnish-cache.org/


---

Traffic Server



Apache Traffic Server


------

Polipo



Polipo — a caching web proxy


Squid



squid : Optimising Web Delivery


Lusca



Lusca Web/Proxy Cache


الكاش هو عبارة عن نظام يقوم بتخزين الملفات سواء كانت صفحات اوخلافة من الانترنت وعن طلبها تخرج منة وليس من الانترنت بسرعة الناقل بين سيرفر الكاش والعميل

ومعظم الناس عندها فكرة خاطئة عن انظمة الكاش

فتسمع يقال كاش mikrotik وكاشSquid

pfsene,I cop ,…..

وخلافة

مع العلم انهم جميعا نفس المخزن او الكاشة او نوع الباكدج المستخدم الا وهو الاسكويد

وهو باكدج لهو اصدارات وليس نظام تشغيل مستقل

ولكنة يقبل النزول على اكثر من نظام

وتختلف الانظمة من نظام لاخر فى التعامل مع الباكدج من نواحى كثيرة

وسوف نتطرق لهذة النقطة فيما بعد حتى لانخرج عن نطاق الدرس

معظم هذة الانظمة تم شرحها هنا فى المنتدى

ولاكن فشلت فشلا كبيرا وذلك اما لعدم معرفة الربط بينة وبين الماكروتك آو تعمد ذالك لمكاسب مادية

المهم

طبعا الشرح هايكون فى الاول على الاسكويد علشان دماغ الناس ما تسحش هههههههه


Lusca

الى هى عبارة عن تطوير لية يعنى من الاخر اخت الاسكويد بس على فكرة اختة دى جامدة قوى ولما ها نشرحها ها تعرفة انها مزة




نجى بقى للمهم الى هو مش ازاى اربط بين الاسكويد والمايكروتك

لا المهم تكون اصلا تكون فاهم العملية بتتم ازاى علشان تعرف تتعامل مع اى سيرفر يعتمد على الاسكويد فى تخزينة

هانعتبر الصفحات بنات اشطة اى خدمة بنات اهو ههههههههههه

العملية دى بتكون مزدوجة بمعنى جزء خاص بالميكروتك وجزء خاص بالاسكويد

العملية فى الاسكويد اسمها اختصار ZPH

Zero Penalty Hit

ودى الخاصةزى ما تقول كدة الكيوز بتاعت الاسكويد يعنى بيعلم على البيكتات الى طالعة منة علشان الستستم الى ورا من اى كان زى المايكروتك يعرف ا ندى جاية من الكاش
نقوم احنا زى ما بتشوفو نعمل حاجتين فى المانجل والكيوز بتاعت المايكروتك
المانجل بيعمل اية نقلو فى حاجت جاية متعلمة لما تجليك عرف الحاجة كيوز بيها
ونقولة اعرفها مثلا ان هاتلاقيها لبسة بنطلون اوف تمام لحد كدة
طبعا الاسكويد معلم على اى بنت كانت عندة قبل كدة متخزنة
التعليم بكون بلغة الهيكس
مثلاx30
دة يساوى 12
فى المايكروتك
نقوم احنا نكتب للمايكروتك 12 فاكدا عملية التعليم تمت وعرف المايكروتك ا ندة جاى من كاش قاعد بقا نقلة يتصرف ازاى مع البنات المتعلمة نقولة اول ما حد يطلب منك بنت من البنات المتعلمين او المتخزنين عندك يطلعهم الكويز بسرعة من غير تحديد العميل ماتتم علية ولينا الحرية اننا نحدد سرعة تانى لية اعلى او نسيبة ديفولت
كدة احنا فهمنا العملية بتتم ازاى
انا اتعمدت اشرح ببساطة علشان الناس ماتخدى كوبى وباسط وخلاص
انا علشان الناس دمغها ما تلفش

انا ها خلى القيم كلها زى بعض اعتماد على ان البكدج المستخدم فى كل الانظمة

0×30 دى = 12 فى المايكروتك

Squid2.7

لانة اكتر اصدار مستقر

نبدا بعون الله

نبدا باعدادت المايكروتك الخاصة بالتخريج بعيد عن التحديد الخاص بالعميل

الاعدادات دى ها تمشى معانا على طول الطريق

/ip firewall mangle

add action=mark-packet chain=postrouting comment=mando_Cache dscp=12 new-packet-mark=cachemando passthrough=no

/queue tree

add name=Cache_Queue packet-mark= cachemando parent=global-out priority=8 queue=default

----===

Ip Cop



/var/ipcop/proxy/advanced/acls/include.acl
tcp_outgoing_tos 0×30 IPCop_green_network
zph_mode tos
zph_local 0×30
zph_parent 0
zph_option 136
----
هذه الصورة تم تصغيرها . إضغط على هذا الشريط لرؤية الصورة بحجمها الطبيعي . أبعاد الصورة الأصلية 640x485 .
Pfsene

# Custom options
zph_mode tos
zph_local 0x30
zph_parent 0
zph_option 136
--====
Smoothwall
#Start of custom includes

#opsi zph
zph_mode tos
zph_local 0x30
zph_parent 0
zph_option 136
#End of custom includes
----===


ClearOs

# NETWORK OPTIONS
# —————————————————————————–

http_port 3128 transparent
zph_mode tos
zph_local 0×30
zph_parent 0
zph_option 136

ClarkConnect

# NETWORK OPTIONS
http_port 8080 transparent
# zph
zph_mode tos
zph_local 0×30
zph_parent 0
zph_option 136






Squid 2.7 ubuntu 10.04

tcp_outgoing_tos 0x30 localnetwork
zph_mode tos
zph_local 0x30
zph_parent 0
zph_option 136

نجى بقى لطرق الربط بينهم اقصد الاسكويد والمايكرتك
ودى بعض الطرق المستخدمة فى الربط بين الاتنين
انا ها اشرح 3 طرق للربط بين الاسكويد والمايكروتك حاليا والباقى بعدين علشان انا صوابعى وجعتنى
ممكن نربطهم على التوالى زى ما الكل بعمل
زى كدة

هذه الصورة تم تصغيرها . إضغط على هذا الشريط لرؤية الصورة بحجمها الطبيعي . أبعاد الصورة الأصلية 507x513 .




والاعدات بتعت الربط ها تكون عادية جدا ما فية غير الاسكربت بتاع التخريج السابق







وممكن نربط بينهم على التوازى زى كدة

هذه الصورة تم تصغيرها . إضغط على هذا الشريط لرؤية الصورة بحجمها الطبيعي . أبعاد الصورة الأصلية 552x393 .

لاكن سعتها ها نضيف فى المايكروتك الاعدادت التالية

نركب 3 كروت فى المايكروتك واحد نت والتانى كاش والتالث خروج عملاء

, Mikrotik have 3 LAN interfaces, . . .





1
2
3
4
/ip address
add address=192.168.0.1/24 disabled=no interface=ether1 network=192.168.0.0
add address=192.168.2.1/24 disabled=no interface=ether2 network=192.168.2.0
add address=192.168.1.2/24 disabled=no interface=ether3 network=192.168.1.0
دى ا ناس كدة بالضبط نعمل


/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=8000KiB max-udp-packet-size=512 servers=192.168.1.1










/ip firewall nat
add action=accept chain=srcnat disabled=no dst-port=80 protocol=tcp

/ip firewall mangle
add action=mark-routing chain=prerouting disabled=no dst-port=80 new-routing-mark=http passthrough=yes protocol=tcp

add action=masquerade chain=srcnat disabled=no out-interface=ether3






/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.2 routing-mark=http scope=30 target-scope=10
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=30 target-scope=

دة طبعا غير الاعدات بتاعت
التخريج الى سبقت






وممكن الطريقة دى



ودى تتم عبر تفعيل الكاش الخاص بالمايكروتك وتفعيل خاصيل الكاش البعيد زى كدة




جارى اعدادا شروحات اكثر والف شكر للاخ ماندو على توضيح النقط دى

24-04-2013, 12:29 PM
Eng Ahmed غير متصل
الوسـام الماسـي
رقم العضوية: 95157
تاريخ التسجيل: Aug 2007
الإقامة: Kuwait
المشاركات: 5,638
إعجاب: 2,801
تلقى 720 إعجاب على 133 مشاركة
تلقى دعوات الى: 2036 موضوع
مواضيع لم تعجبه: 0
تلقى 0 عدم اعجاب على 0 مشاركة
    #3  
جزاك الله خيرا أخي الحبيب
مجهود رائع ومميز
--
ولكن عندى طلب بسيط

موضوع يكون عن المايكروتيك من البدايه الى النهايه


<< لا اله الا انت سبحانكـ , انى كنت من الظالمين >>
=============
Eng. Ahmed Ali El-sayed
[ Damas Silent Team ]
------------------------
«(«( مواضيعي )»)»


 


الموضوع الرسمى الخاص بسيرفرات الكاش وشروحاتها ..ِشادى سوفت


Powered by vBulletin® Version
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
The owner and operator of the site is not responsible for the availability of, or any content provided.
Topics that are written in the site reflect the opinion of the author.
جميع ما يُطرح من مواضيع ومشاركات تعبر عن رأي كاتبها ولا تعبر عن رأي مالك الموقع أو الإدارة بأي حال من الأحوال.