Genuine Key


Genuine Key


Moved to new forum, Click Here to register

تم الانتقال للمنتدى الجديد, اضغط هنا للتسجيل
Icon14 سكربت لمعرفة كمية استهلاك الخط طول الشهر

عاوز تعرف انت استهلكت جيجات اد ايه من خطك طول الشهر
انا جبت الاسكربت والشرح موجود على اليوتيوب لاكن الاسكربت اتحذف وانا جبتهولك
هتغير "in2"لاسم خط النت اللى داخل للسيرفر
وهتغير الايبى لايبى الراوتر فى الفتحه اللى انت موصل فيها

:global in "in2"
/ip firewall mangle
add action=mark-packet chain=prerouting comment=shadydown disabled=no dst-address=\
!192.168.10.1 new-packet-mark=shadysoft-down passthrough=yes
add action=mark-packet chain=postrouting comment=shadyup disabled=no \
new-packet-mark=shadysoft-up out-interface=in2 passthrough=yes
/interface bridge
add name=m-down comment="0"
add name=m-up comment="0"
}
/system scheduler
add interval=1h name=shadysoft on-event=shadysoft

--------------------------------------
داخل السيكربت "shadysoft"

--
:local firwd [/ip firewall mangle find where comment=shadydown];
:local shadyd;
:set shadyd [/ip firewall mangle get [:pick $firwd] bytes];
:local firwup [/ip firewall mangle find where comment=shadyup];
:local shadyu;
:set shadyu [/ip firewall mangle get [:pick $firwup] bytes];
:local a 99;
:local b 85;
:local u ($a/$b);
:local upreal ($u*$shadyu);
:local downreal ($shadyd-$upreal);
:local interin [/interface bridge find where name=m-down];
:local shadyi;
:set shadyi [/interface bridge get [:pick $interin] comment];
:local interout [/interface bridge find where name=m-up];
:local shadyout;
:set shadyout [/interface bridge get [:pick $interout] comment];
:local j 1048576;
:local bytedown ($downreal/$j);
:local byteup ($upreal/$j);
:local bytedafterget ($bytedown+$shadyi);
:local byteupafterget ($byteup+$shadyout);
:if ($shadyd != 0) do=--
/interface bridge set numbers=m-down comment="$bytedafterget"
/interface bridge set numbers=m-up comment="$byteupafterget"
/ip firewall mangle reset-counters $firwd
/ip firewall mangle reset-counters $firwup
}
}

المواضيع المشابهه

الرجاء المساعدة لمعرفة نوع الخط في الصورة

ينفع اقدم في كلية تانية اقصد معهد خاص او جامعة خاصة وليست كلية حكومية ؟

لمعرفت وقت بداية الشهر القمري

برنامج روعة لمعرفة كمية التحميل لاصحاب التحميل المحدود


شكرا لك اخي العزيز


أدوات الموضوع

الانتقال السريع

منتديات داماس

DamasGate